Главная страница

Поиск элемента по заданному свойству. Поиск элемента по заданному свойству


Скачать 170.5 Kb.
НазваниеПоиск элемента по заданному свойству
Дата11.07.2019
Размер170.5 Kb.
Формат файлаppt
Имя файлаПоиск элемента по заданному свойству.ppt.ppt
ТипРешение
#83952

Поиск элемента по заданному свойству

Массив А


Сколько элементов массива равно 4?
Назовите номер элемента , который равен -15


i


1


2


3


4


5


6


7


8


9


10


A[i]


4


6


0


-6


-15


4


3


0


1


2

Задача1


С клавиатуры вводятся 10 элементов массива. Выведите на экран количество нулей.

Решение


алг Кол-во_нулей нач вещтаб A[1:10],цел i, k
вывод "введи массив", нс
i:=1; k:=0
нц для i от 1 до 10
ввод A[i]
если A[i]=0
то k:=k+1
все кц вывод k
кон

Задача2


С клавиатуры вводятся 10 элементов массива. Выведите на экран номера элементов, равных 7.

Внесите изменения


алг Кол-во_нулей нач вещтаб A[1:10],цел i,вещ k
вывод "введи массив", нс
i:=1; k:=0
нц для i от 1 до 10
ввод A[i]
если A[i]=0
то k:=k+1
все кц вывод k
кон

Домашнее задание


В соревнованиях по стрельбе участвует 120 человек. Написать программу, которая выдает кол-во спортсменов, прошедших квалификационные испытания.
Примечание: квалификацию проходят те, кто набрал более 85 очков из 100.


написать администратору сайта